Перейти к содержимому


Фотография

Динамический шейпер v.1-2


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 10

Опрос: Динамический шейпер v.1-2 (6 пользователей проголосовало)

Оказался ли полезным для вас скрипт Shaper?

  1. Версия 1 (0 голосов [0.00%])

    Процент голосов: 0.00%

  2. Версия 2 (2 голосов [33.33%] - Просмотр)

    Процент голосов: 33.33%

  3. Еще не пробовал. (4 голосов [66.67%] - Просмотр)

    Процент голосов: 66.67%

  4. Скрипт бесполезен и не пригоден для работы (0 голосов [0.00%])

    Процент голосов: 0.00%

Голосовать Гости не могут голосовать

#1 Inlarion

Inlarion

    Администратор

  • Administrators
  • 336 сообщений
  • LocationЧелябинск

Отправлено 09 Январь 2011 - 19:03

Ветка для обсуждения скриптов Shaper v.1 v.2
Суровый Челябинский сисадмин :)

#2 SScratch

SScratch

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 14 Январь 2011 - 10:18

Mikrotik v3.30
Скрипт шейпера V2 после отработки убирает в правилах очереди "Packet Marks", и правила становятся бесполезными :)

#3 Inlarion

Inlarion

    Администратор

  • Administrators
  • 336 сообщений
  • LocationЧелябинск

Отправлено 14 Январь 2011 - 20:40

Mikrotik v3.30
Скрипт шейпера V2 после отработки убирает в правилах очереди "Packet Marks", и правила становятся бесполезными :)

Спасибо, обязательно потестим и поправим.
Суровый Челябинский сисадмин :)

#4 SScratch

SScratch

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 15 Январь 2011 - 16:15

В скриптах не силен и поэтому
Ничего умнее не придумал как изменить немного пару строк:

/queue tree set [/queue tree find name=[:pick $activedownusers ($dcount-1)] . "_down"] packet-mark=([:pick $activedownusers ($dcount-1)] ."_down") max-limit=$maxlimitdown; };
/queue tree set [/queue tree find name=[:pick $activeupusers ($dcount-1)] . "_up"] packet-mark=([:pick $activeupusers ($dcount-1)] ."_up") max-limit=$maxlimitup; };

#5 Inlarion

Inlarion

    Администратор

  • Administrators
  • 336 сообщений
  • LocationЧелябинск

Отправлено 16 Январь 2011 - 05:57

В скриптах не силен и поэтому
Ничего умнее не придумал как изменить немного пару строк:

/queue tree set [/queue tree find name=[:pick $activedownusers ($dcount-1)] . "_down"] packet-mark=([:pick $activedownusers ($dcount-1)] ."_down") max-limit=$maxlimitdown; };
/queue tree set [/queue tree find name=[:pick $activeupusers ($dcount-1)] . "_up"] packet-mark=([:pick $activeupusers ($dcount-1)] ."_up") max-limit=$maxlimitup; };

Да, все верно сделали, еще можно было вывести в две отдельные переменные для экономии процессорного времени.
Суровый Челябинский сисадмин :)

#6 KillBill

KillBill

    Новичок

  • Members
  • Pip
  • 1 сообщений

Отправлено 04 Июнь 2011 - 01:30

Скрипт очень полезен, но хотелось бы узнать каким все таки образом пользователь попадает в список активных? Насколько я понял активным считается тот, кто за время действия скрипта 1-2 сек скачал больше чем Activethresholddown?
Я внес изменения согласно комментариям Inlarion, все заработало так как и задумывалось, но есть один ньюанс - хотелось бы, чтобы в правилах очереди maxlimitdown выставлялся всем пользователям, а не только акивным. Подскажите что нужно подправить в

/queue tree set [/queue tree find name=[:pick $activedownusers ($dcount-1)] . "_down"] packet-mark=([:pick $activedownusers ($dcount-1)] ."_down") max-limit=$maxlimitdown; };
/queue tree set [/queue tree find name=[:pick $activeupusers ($dcount-1)] . "_up"] packet-mark=([:pick $activeupusers ($dcount-1)] ."_up") max-limit=$maxlimitup; };

Дело в том что у меня канал в 8М, когда активных пользователей >40 то этим пользователям выставляется лимит в 200k соответственно, но скорость то пиковая, пользователь загрузил страничку за 2 сек с хорошей скоростью и пошел спать, а лимит на скачивание в очереди остался прежним в 200k. Встает он утром, канал разгружен, хочет скачать что нибудь на хорошей скорости, да не может т.к. он не попадает в число активных пользователей, т.к. ему канал урезан и тот порог activethresholddown перескочить не может.

#7 Inlarion

Inlarion

    Администратор

  • Administrators
  • 336 сообщений
  • LocationЧелябинск

Отправлено 06 Июнь 2011 - 08:42

Выставлять всем пользователям лимит не получится потому, что скрипт итак много ресурсов кушает...
Не устанавливайте activethresholddown слишком высоким, достаточно нескольких десятков килобайт.
Суровый Челябинский сисадмин :)

#8 victorpvn

victorpvn

    Пользователь

  • Members
  • PipPip
  • 25 сообщений
  • LocationUB

Отправлено 14 Май 2012 - 06:51

Можно ли показать в winbox чтоб видеть визуально а то скрипты еще не изучал трудно понять?

#9 sattva

sattva

    Пользователь

  • Members
  • PipPip
  • 10 сообщений

Отправлено 06 Октябрь 2012 - 11:47

у меня не работает:
script error: no such item

прошу помощи

#10 sattva

sattva

    Пользователь

  • Members
  • PipPip
  • 10 сообщений

Отправлено 07 Октябрь 2012 - 07:08

Вручную через winbox - добавил в Queue Tree: Download global(без -out) и Upload global(без -out) - после этого запустился без ошикок 2-й скрипт и соответсвенно заработал 3-й

--------------------------------------------
RouterOS v6rc1

#11 sattva

sattva

    Пользователь

  • Members
  • PipPip
  • 10 сообщений

Отправлено 08 Октябрь 2012 - 14:06

пожелание помодернизации скрипта:
в случаи переключения на резервный канал, скорость которого существенно отличается от основного было бы замечательно если бы:
:local MaxRateDownload ("15000000");
:local MaxRateUpload ("15000000");

также менялись




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных