Перейти к содержимому


Фотография

Mikrotik + IPTV (IGMP Proxy)


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1 TEma

TEma

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 16 Сентябрь 2015 - 09:06

Добрый день, помогите разобраться с настройкой Mikrotik IGMP Proxy. 

Всё настроил, работает но не долго, пару минут идёт трансляция, а потом застывает картинка, при переключении каналов опять заводится, но не на долго, опять зависает. 
В MFC создаются динамические маршруты, пакеты бегают, после зависания картинки в MFC отпадают все маршруты и всё.

 

Работает только при статическом маршруте, который надо прописывать для каждого канала отдельно:

 

/routing igmp-proxy mfc add source=172.16.18.250 upstream-interface=DKS downstream-interface=Port-3 group=239.0.0.108 disabled=no



Мои настройки: 

Настройки IGMP Proxy: 
/routing igmp-proxy interface print detail 
Flags: X - disabled, I - inactive, D - dynamic, U - upstream 
0 U interface=DKS threshold=1 alternative-subnets=0.0.0.0/0 upstream=yes 

1 interface=Port-3 threshold=1 alternative-subnets="" upstream=no 

DKS - кабель от провайдера (WAN) 
Port-3 - порт к которому подключен Я. 

Настройки firewall: 
/ip firewall filter print detail where !disabled 
Flags: X - disabled, I - invalid, D - dynamic 
0 chain=input action=accept protocol=igmp log=no log-prefix="" 

1 chain=input action=accept protocol=udp dst-port=1234 log=no log-prefix="" 

2 ;;; Winbox 
chain=input action=accept protocol=tcp dst-port=8291 log=no log-prefix="" 

Настройка Routes: 

/ip route print detail 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 

0 ADS dst-address=0.0.0.0/0 gateway=195.211.172.21 
gateway-status=195.211.172.21 reachable via pptp-out1 dista 
scope=30 target-scope=10 

1 A S dst-address=10.0.0.0/8 gateway=10.2.230.1 
gateway-status=10.2.230.1 reachable via DKS distance=1 scop 
target-scope=10 

2 ADS dst-address=10.2.2.21/32 gateway=10.2.230.1 
gateway-status=10.2.230.1 reachable via DKS distance=0 scop 
target-scope=10 

3 ADC dst-address=10.2.230.0/24 pref-src=10.2.230.95 gateway=DKS 
gateway-status=DKS reachable distance=0 scope=10 

4 ADC dst-address=192.168.1.0/24 pref-src=192.168.1.1 gateway=bridge 
gateway-status=bridge reachable distance=0 scope=10 

5 ADC dst-address=192.168.10.0/24 pref-src=192.168.10.1 gateway=Port-3 
gateway-status=Port-3 reachable distance=0 scope=10 

6 ADC dst-address=195.211.172.21/32 pref-src=31.43.22.172 gateway=pptp-out1 
gateway-status=pptp-out1 reachable distance=0 scope=10 

7 A S dst-address=224.0.0.0/8 gateway=10.2.230.1 
gateway-status=10.2.230.1 reachable via DKS distance=1 scope=30 
target-scope=10 

8 A S dst-address=239.0.0.0/8 gateway=10.2.230.1 
gateway-status=10.2.230.1 reachable via DKS distance=1 scope=30 
target-scope=10 

Версия прошивки: 
system routerboard print 
routerboard: yes 
model: 750 
serial-number: 2F2C0138B725 
current-firmware: 3.0 
upgrade-firmware: 3.24 

Версии ПО: 
/system package print 
Flags: X - disabled 
# NAME VERSION SCHEDULED 
0 multicast 6.30.4 
1 routeros-mipsbe 6.30.4 
2 system 6.30.4 
3 X wireless-cm2 6.30.4 
4 ipv6 6.30.4 
5 wireless-fp 6.30.4 
6 hotspot 6.30.4 
7 dhcp 6.30.4 
8 mpls 6.30.4 
9 routing 6.30.4 
10 ppp 6.30.4 
11 security 6.30.4 
12 advanced-tools 6.30.4



#2 TEma

TEma

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 23 Сентябрь 2015 - 08:25

Заработало всё вот с такими настройками:

/routing igmp-proxy interface print detail
Flags: X - disabled, I - inactive, D - dynamic, U - upstream 
0 U interface=DKS threshold=1 alternative-subnets=0.0.0.0/0 upstream=yes 

1 interface=Port-3 threshold=1 alternative-subnets=192.168.10.0/24 
upstream=no 
DKS - кабель от провайдера (WAN)
Port-3 - порт к которому подключен Я.
192.168.10.0/24 - моя внутренняя сеть на Port-3.

/routing igmp-proxy print
quick-leave: yes
query-interval: 20m
query-response-interval: 10s

Остальные настройки выше.
+ надо добавить статический маршрут:
/routing igmp-proxy mfc add source=172.16.18.252 upstream-interface=DKS downstream-interface=Port-3 group=239.0.0.252 disabled=no
Без него вещание будет, но через некоторое время опять обрыв... у меня с такими настройками 3 дня работает на отлично.






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных