Перейти к содержимому


Фотография

Перенаправлять пакеты внутри сети при запросе внешнего адреса


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1 qwin

qwin

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 24 Ноябрь 2014 - 05:16

Добрый день! 

mikrotik rb1100

Появилась следующая задача перенаправлять пакет при запросе с внутренней сети 192.168.1.0/24 внешнего адреса x.x.x.x по  порту 8100 перенаправлять на адрес 192.168.1.64 порт 8000

 

c внешки данное правило срабатывает: netmap to adresses 192.168.1.64 to port 8000 dstnat  protokol 6(tcp) dst.port 8100 in.interface Lan

 

вопрос как сделать правило чтобы внутри сети срабатывало перенаправление при запросе внешнего адреса 

 

192.168.1.0/24-->x.x.x.x:8100-->192.168.1.64:8000



#2 qwin

qwin

    Новичок

  • Members
  • Pip
  • 2 сообщений

Отправлено 25 Ноябрь 2014 - 08:00

 

Нашел выход из ситуации:

маскарадим пакеты 

/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 \
dst-address=192.168.1.64 protocol=tcp dst-port=8000 \
out-interface=LAN action=masquerade

перенаправляем на порт с внешки на локалку

/ip firewall nat
add chain=dstnat src-address=192.168.1.0/24

\ dst-address=x.x.x.x protocol=tcp dst-port=8100\
action=dst-nat to-address=192.168.1.64 to ports 8000
 






Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных