Перейти к содержимому


Фотография

2 WAN в 1 LAN


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1 stark87

stark87

    Новичок

  • Members
  • Pip
  • 1 сообщений

Отправлено 14 Сентябрь 2014 - 13:35

Всем  здравствуйте

Подскажите как можно решить данную проблему

-----------

Имеется  (все статика)

WAN1-

IP 192.168.1.2/24

GW 192.168.1.1

WAN2-

IP 192.168.137.2/24

GW192.168.137.1

LAN-

IP 192.168.0.1/24

------------

В LAN трафик с компьютеров с IP 192.168.0.20-192.168.0.25 проходил по WAN2, все остальное  проходит по WAN1.

# 1 Static address
/ip address add disabled=no address=192.168.1.2/24 interface=WAN1 comment=WAN1
/ip address add disabled=no address=192.168.137.2/24 interface=WAN2 comment=WAN2

# 2 Add DNS
/ip dns set servers=8.8.8.8 allow-remote-requests=yes

# 3 Add default route
/ip route add disabled=no comment=WAN1 dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=3 check-gateway=arp scope=31
/ip route add disabled=no comment=WAN2 dst-address=0.0.0.0/0 gateway=192.168.137.1 distance=4 check-gateway=arp scope=31

# 4 Add Address List
/ip firewall address-list add disabled=no address=192.168.0.20 list=VoIP
/ip firewall address-list add disabled=no address=192.168.0.21 list=VoIP
/ip firewall address-list add disabled=no address=192.168.0.22 list=VoIP
/ip firewall address-list add disabled=no address=192.168.0.23 list=VoIP
/ip firewall address-list add disabled=no address=192.168.0.24 list=VoIP
/ip firewall address-list add disabled=no address=192.168.0.25 list=VoIP

# 5 Add NAT
/ip firewall nat add disabled=no action=masquerade chain=srcnat out-interface=WAN1 comment=WAN1 src-address-list=!VoIP 
/ip firewall nat add disabled=no action=masquerade chain=srcnat out-interface=WAN2 comment=WAN2 src-address-list=VoIP

# 6 Add mangle
/ip firewall mangle add disabled=no comment=WAN1 in-interface=WAN1 connection-mark=no-mark chain=prerouting action=mark-connection new-connection-mark=WAN1_conn
/ip firewall mangle add disabled=no comment=WAN2 in-interface=WAN2 connection-mark=no-mark chain=prerouting action=mark-connection new-connection-mark=WAN2_conn
/ip firewall mangle add disabled=no comment=WAN1 connection-mark=WAN1_conn chain=output action=mark-routing new-routing-mark=to_WAN1 passthrough=yes 
/ip firewall mangle add disabled=no comment=WAN2 connection-mark=WAN2_conn chain=output action=mark-routing new-routing-mark=to_WAN2 passthrough=yes
# 7 Add route
/ip route add disabled=no comment=WAN1 dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=3 check-gateway=arp routing-mark=to_WAN1
/ip route add disabled=no comment=WAN2 dst-address=0.0.0.0/0 gateway=192.168.137.1 distance=4 check-gateway=arp routing-mark=to_WAN2

проблема в следующем... при одновременных выткнутых  WAN1 WAN2 , интернет есть у всех кроме списка VoIP.  Если WAN1 отключен то инет есть у списка VoIP.

когда я добавил (# 3 Add default route) у меня 1 активный, 2-ой неактивный....

2b5f58195baf.jpg

как можно  это исправить чтоб  WAN1 WAN2  одновременно работали в  LAN?



#2 Inlarion

Inlarion

    Администратор

  • Administrators
  • 336 сообщений
  • LocationЧелябинск

Отправлено 26 Сентябрь 2014 - 06:44

/ip firewall nat add disabled=no action=masquerade chain=srcnat out-interface=WAN1 comment=WAN1 src-address-list=!VoIP
/ip firewall nat add disabled=no action=masquerade chain=srcnat out-interface=WAN2 comment=WAN2 src-address-list=VoIP

 

Ваш главный костыль, NAT должен использоваться по прямому назначению а не для ограничения доступа и уж тем более для разводки по каналам.

 

http://mikrotik.axio...oupbalancer.php


Суровый Челябинский сисадмин :)




Количество пользователей, читающих эту тему: 0

0 пользователей, 0 гостей, 0 анонимных